You are not allowed to change the code above] Subtasks: 1. Create a Doll class. 2. Create the required constructor. 3. Write a method to print the name and the price of the object 4. Use operator overloading for the addition operators. 5. Write a method to handle operator overloading for the ">" logical operator that compares the price of the objects. Hints: Notice that the price of each object is being checked with the price of obj in the given code. • Notice the word Doll in the first 4 outputs and the last output. You have to print exactly as represented here. Task 8 Design a class called Coordinates with an appropriate constructor. Then perform the subtraction, multiplication and equality check operations in the given code using operator overloading. #Write your code here Sample Input 1: 1 #Do not change the following lines of code 2 3 4 p1 = Coordinates(int(input()), int(input())) p2 = Coordinates(int(input()), int(input()) Sample Output 1: (-2,-2) (3,8) The calculated coordinates are NOT the same. Sample Input 2: p4 = p1 - p2 print(p4.detail()) p5 = p1 * p2 print(p5.detail()) Sample Output 2: (0,0) (0,0) The calculated coordinates are the same. point_check = (p4 == p5) print(point_check)

Computer Networking: A Top-Down Approach (7th Edition)
7th Edition
ISBN:9780133594140
Author:James Kurose, Keith Ross
Publisher:James Kurose, Keith Ross
Chapter1: Computer Networks And The Internet
Section: Chapter Questions
Problem R1RQ: What is the difference between a host and an end system? List several different types of end...
icon
Related questions
Question

#this is a python program

topic:  operation overloading, Encapsulation

please find the attached image

You are not allowed to change the code above]
Subtasks:
1. Create a Doll class.
2. Create the required constructor.
3. Write a method to print the name and the price of the object
4. Use operator overloading for the addition operators.
5. Write a method to handle operator overloading for the ">" logical operator that
compares the price of the objects.
Hints:
• Notice that the price of each object is being checked with the price of obj in the
given code.
• Notice the word Doll in the first 4 outputs and the last output. You have to print
exactly as represented here.
Task 8
Design a class called Coordinates with an appropriate constructor. Then perform the
subtraction, multiplication and equality check operations in the given code using
operator overloading.
Sample Input 1:
1
#Write your code here
#Do not change the following lines of code
2
3
p1 =
Coordinates(int(input()), int(input())
p2 =
Coordinates(int(input()), int(input())
4
Sample Output 1:
(-2,-2)
(3,8)
The calculated coordinates are NOT the
p4 = p1 - p2
print(p4.detail())
same. Sample Input 2:
p5 = p1 * p2
print(p5.detail())
Sample Output 2:
(0,0)
(0,0)
The calculated coordinates are the same.
point_check = (p4 = p5)
print(point_check)
Transcribed Image Text:You are not allowed to change the code above] Subtasks: 1. Create a Doll class. 2. Create the required constructor. 3. Write a method to print the name and the price of the object 4. Use operator overloading for the addition operators. 5. Write a method to handle operator overloading for the ">" logical operator that compares the price of the objects. Hints: • Notice that the price of each object is being checked with the price of obj in the given code. • Notice the word Doll in the first 4 outputs and the last output. You have to print exactly as represented here. Task 8 Design a class called Coordinates with an appropriate constructor. Then perform the subtraction, multiplication and equality check operations in the given code using operator overloading. Sample Input 1: 1 #Write your code here #Do not change the following lines of code 2 3 p1 = Coordinates(int(input()), int(input()) p2 = Coordinates(int(input()), int(input()) 4 Sample Output 1: (-2,-2) (3,8) The calculated coordinates are NOT the p4 = p1 - p2 print(p4.detail()) same. Sample Input 2: p5 = p1 * p2 print(p5.detail()) Sample Output 2: (0,0) (0,0) The calculated coordinates are the same. point_check = (p4 = p5) print(point_check)
Expert Solution
steps

Step by step

Solved in 4 steps with 3 images

Blurred answer
Recommended textbooks for you
Computer Networking: A Top-Down Approach (7th Edi…
Computer Networking: A Top-Down Approach (7th Edi…
Computer Engineering
ISBN:
9780133594140
Author:
James Kurose, Keith Ross
Publisher:
PEARSON
Computer Organization and Design MIPS Edition, Fi…
Computer Organization and Design MIPS Edition, Fi…
Computer Engineering
ISBN:
9780124077263
Author:
David A. Patterson, John L. Hennessy
Publisher:
Elsevier Science
Network+ Guide to Networks (MindTap Course List)
Network+ Guide to Networks (MindTap Course List)
Computer Engineering
ISBN:
9781337569330
Author:
Jill West, Tamara Dean, Jean Andrews
Publisher:
Cengage Learning
Concepts of Database Management
Concepts of Database Management
Computer Engineering
ISBN:
9781337093422
Author:
Joy L. Starks, Philip J. Pratt, Mary Z. Last
Publisher:
Cengage Learning
Prelude to Programming
Prelude to Programming
Computer Engineering
ISBN:
9780133750423
Author:
VENIT, Stewart
Publisher:
Pearson Education
Sc Business Data Communications and Networking, T…
Sc Business Data Communications and Networking, T…
Computer Engineering
ISBN:
9781119368830
Author:
FITZGERALD
Publisher:
WILEY