Using loops of any kind, lists, Range, Sets, etc NOT allowed Angela loves reading books. She recently started reading an AI generated series called “Harry Trotter”. Angela is collecting books from the series at her nearest bookstore. Since the series is AI generated, the publishers have produced an infinite collection of the books where each book is identified by a unique integer. The bookstore has exactly one copy of each book. Angela wants to buy the books in the range [l,r], where l ≤ r. As an example, the range [−3,3] means that Angela wants to buy the books − 3, − 2, − 1, 0, 1, 2, and 3. Dan also loves the series (or maybe annoying Angela – who knows, really), and he manages to sneak into the bookstore very early to buy all of the books in the range [d,u], where d ≤ u. When Angela later visits, sadly she will not find those books there anymore. For example, if Angela tries to buy books [−2,3] and Dan has bought books [0,2], Angela would only receive books − 2, − 1, and 3. The reading recommendation score of the books is the product of the book numbers received. So if Angela gets books − 2, − 1, and 3, for instance, the reading recommendation score will be − 2 × − 1 × 3 = 6. Your task is to write a program that will help Angela determine whether the reading recommendation score of the books she receives is NEGATIVE, ZERO, POSITIVE, or EMPTY. Filename Your filename for this question must be q2.py. Input There are four lines of input. The first line of input will contain the integer l, the lower bound of the collection of books that Angela would like to buy. The second line of input will contain the integer r, the upper bound of the collection of books that Angela would like to buy. The third line of input will contain the integer d, the lower bound of the collection of books that Dan buys. The fourth line of input will contain the integer u, the upper bound of the collection of books that Dan buys. Output Let s be the reading recommendation score of the book collection Angela receives. If s is less than 0, print NEGATIVE. If s is exactly 0, print ZERO. If s is greater than 0, print POSITIVE. If s does not exist, print EMPTY. Sample Input 1 1 10 3 7 Sample Output 1 POSITIVE Sample Input 2 1 3 1 3 Sample Output 2 EMPTY Sample Input 3 -5 5 -2 3 Sample Output 3 NEGATIVE Sample Input 4 -1 3 -2 -1 Sample Output 4 ZERO
Using loops of any kind, lists, Range, Sets, etc NOT allowed
Angela loves reading books. She recently started reading an
Angela is collecting books from the series at her nearest bookstore. Since the series is AI generated, the publishers have produced an infinite collection of the books where each book is identified by a unique integer. The bookstore has exactly one copy of each book.
Angela wants to buy the books in the range [l,r], where l ≤ r. As an example, the range [−3,3] means that Angela wants to buy the books − 3, − 2, − 1, 0, 1, 2, and 3.
Dan also loves the series (or maybe annoying Angela – who knows, really), and he manages to sneak into the bookstore very early to buy all of the books in the range [d,u], where d ≤ u. When Angela later visits, sadly she will not find those books there anymore.
For example, if Angela tries to buy books [−2,3] and Dan has bought books [0,2], Angela would only receive books − 2, − 1, and 3.
The reading recommendation score of the books is the product of the book numbers received. So if Angela gets books − 2, − 1, and 3, for instance, the reading recommendation score will be − 2 × − 1 × 3 = 6.
Your task is to write a program that will help Angela determine whether the reading recommendation score of the books she receives is NEGATIVE, ZERO, POSITIVE, or EMPTY.
Filename
Your filename for this question must be q2.py.
Input
There are four lines of input.
- The first line of input will contain the integer l, the lower bound of the collection of books that Angela would like to buy.
- The second line of input will contain the integer r, the upper bound of the collection of books that Angela would like to buy.
- The third line of input will contain the integer d, the lower bound of the collection of books that Dan buys.
- The fourth line of input will contain the integer u, the upper bound of the collection of books that Dan buys.
Output
Let s be the reading recommendation score of the book collection Angela receives.
- If s is less than 0, print NEGATIVE.
- If s is exactly 0, print ZERO.
- If s is greater than 0, print POSITIVE.
- If s does not exist, print EMPTY.
Sample Input 1
1 10 3 7
Sample Output 1
POSITIVE
Sample Input 2
1 3 1 3
Sample Output 2
EMPTY
Sample Input 3
-5 5 -2 3
Sample Output 3
NEGATIVE
Sample Input 4
-1 3 -2 -1
Sample Output 4
ZERO
We will create a list first for available books which will store the numbers [l,r].
Then similarly we will create a list for Dan which will store the number [d,u].
here we use math function
import math
#taking all 4 required inputs and storing them in variables.
l = int(input("enter the value of l: "))
r = int(input("enter the value of r: "))
d = int(input("enter the value of d: "))
u = int(input("enter the value of u: "))
#create the list by using range() function
#The range() function returns a series of numbers that, by default, starts at 0 and increments by 1 before stopping before a given number.
#we use : range(start index, end index + 1, increment)
original_list = [*range(l, r+1, 1)]
dan_list = [*range(d, u+1, 1)]
Step by step
Solved in 5 steps with 4 images