A good string is a string or a substring that starts with the character "g" and ends with the character "d". For a given string, write a program to find the number of "good substrings" of a given string. Note - A substring of a string is a contiguous subsequence of that string. The list of all non-empty substrings of the string "apple" would be "apple", "appl", "pple", "app", "ppl", "ple", "ap", "pp", "pl", "le", "a", "p", "p", "T", and "e" There will be multiple test cases running so the Input and Output should match exactly as provided. The base output variable result is set to a default value of -404 which can be modified. Additionally, you can add or remove these output variables. Input Format The first line contains the string S. Sample Input godk - denotes S Constraints 1 <= len|S| <= 100 Output Format The output contains a single integer denoting the number of good substrings of the given string. Sample Output 1 Explanation In the given string, only one substring "god" is good. Hence, the answer is 1

Computer Networking: A Top-Down Approach (7th Edition)
7th Edition
ISBN:9780133594140
Author:James Kurose, Keith Ross
Publisher:James Kurose, Keith Ross
Chapter1: Computer Networks And The Internet
Section: Chapter Questions
Problem R1RQ: What is the difference between a host and an end system? List several different types of end...
icon
Related questions
Question
Please code the following code in JavaScript (Node.js 12.14.0) according to the function given
A good string is a string or a substring that starts with the character "g" and ends with the character "d".
For a given string, write a program to find the number of "good substrings" of a given string.
Note
- A substring of a string is a contiguous subsequence of that string.
The list of all non-empty substrings of the string "apple" would be "apple", "appl", "pple", "app", "ppl", "ple", "ap", "pp", "pl", "le", "a", "p", "p", "I", and "e"
There will be multiple test cases running so the Input and Output should match exactly as provided.
The base output variable result is set to a default value of -404 which can be modified. Additionally, you can add or remove these output variables.
Input Format
The first line contains the string S.
Sample Input
godk -- denotes S
Constraints
1 <= len|S| <= 100
Output Format
The output contains a single integer denoting the number of good substrings of the given string.
Sample Output
1
Explanation
In the given string, only one substring "god" is good.
Hence, the answer is 1
Transcribed Image Text:A good string is a string or a substring that starts with the character "g" and ends with the character "d". For a given string, write a program to find the number of "good substrings" of a given string. Note - A substring of a string is a contiguous subsequence of that string. The list of all non-empty substrings of the string "apple" would be "apple", "appl", "pple", "app", "ppl", "ple", "ap", "pp", "pl", "le", "a", "p", "p", "I", and "e" There will be multiple test cases running so the Input and Output should match exactly as provided. The base output variable result is set to a default value of -404 which can be modified. Additionally, you can add or remove these output variables. Input Format The first line contains the string S. Sample Input godk -- denotes S Constraints 1 <= len|S| <= 100 Output Format The output contains a single integer denoting the number of good substrings of the given string. Sample Output 1 Explanation In the given string, only one substring "god" is good. Hence, the answer is 1
1 function solution (str) {
Y
123 458
7
6 function main() {
9
10
12-
13
15
16
18
}
20
// write your code here
return 0;
}
var readline = require("readline");
var rl = readline.createInterface (process.stdin, process.stdout);
rl.prompt();
let args = []
rl.on("line", (input) => {
});
args.push(input)
if(args.length == 1) {
main();
console.log(solution (args[0]));
rl.close();
Transcribed Image Text:1 function solution (str) { Y 123 458 7 6 function main() { 9 10 12- 13 15 16 18 } 20 // write your code here return 0; } var readline = require("readline"); var rl = readline.createInterface (process.stdin, process.stdout); rl.prompt(); let args = [] rl.on("line", (input) => { }); args.push(input) if(args.length == 1) { main(); console.log(solution (args[0])); rl.close();
Expert Solution
steps

Step by step

Solved in 2 steps with 2 images

Blurred answer
Recommended textbooks for you
Computer Networking: A Top-Down Approach (7th Edi…
Computer Networking: A Top-Down Approach (7th Edi…
Computer Engineering
ISBN:
9780133594140
Author:
James Kurose, Keith Ross
Publisher:
PEARSON
Computer Organization and Design MIPS Edition, Fi…
Computer Organization and Design MIPS Edition, Fi…
Computer Engineering
ISBN:
9780124077263
Author:
David A. Patterson, John L. Hennessy
Publisher:
Elsevier Science
Network+ Guide to Networks (MindTap Course List)
Network+ Guide to Networks (MindTap Course List)
Computer Engineering
ISBN:
9781337569330
Author:
Jill West, Tamara Dean, Jean Andrews
Publisher:
Cengage Learning
Concepts of Database Management
Concepts of Database Management
Computer Engineering
ISBN:
9781337093422
Author:
Joy L. Starks, Philip J. Pratt, Mary Z. Last
Publisher:
Cengage Learning
Prelude to Programming
Prelude to Programming
Computer Engineering
ISBN:
9780133750423
Author:
VENIT, Stewart
Publisher:
Pearson Education
Sc Business Data Communications and Networking, T…
Sc Business Data Communications and Networking, T…
Computer Engineering
ISBN:
9781119368830
Author:
FITZGERALD
Publisher:
WILEY