15. Translate the following C program to Pep/9 assembly language. #include int main() { int numitms, j, data, sum; scanf("%d", &numItms); sum = 0; for (j = 1; j <= numitms; j++) { scanf("%d", &data); sum += data;

Database System Concepts
7th Edition
ISBN:9780078022159
Author:Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Publisher:Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Chapter1: Introduction
Section: Chapter Questions
Problem 1PE
icon
Related questions
Question
15. Translate the following C program to Pep/9 assembly language.
#include <stdio.h>
int main() {
int numitms, j, data, sum;
scanf("%d", &numItms);
sum = 0;
for (j = 1; j <= numitms; j++) {
scanf("%d", &data);
sum += data;
}
printf ("Sum: %d\n", sum);
return 0;
}
Sample Input
48-376
Sample Output
Sum: 18
Transcribed Image Text:15. Translate the following C program to Pep/9 assembly language. #include <stdio.h> int main() { int numitms, j, data, sum; scanf("%d", &numItms); sum = 0; for (j = 1; j <= numitms; j++) { scanf("%d", &data); sum += data; } printf ("Sum: %d\n", sum); return 0; } Sample Input 48-376 Sample Output Sum: 18
Expert Solution
trending now

Trending now

This is a popular solution!

steps

Step by step

Solved in 3 steps

Blurred answer
Knowledge Booster
ADT and Class
Learn more about
Need a deep-dive on the concept behind this application? Look no further. Learn more about this topic, computer-science and related others by exploring similar questions and additional content below.
Similar questions
  • SEE MORE QUESTIONS
Recommended textbooks for you
Database System Concepts
Database System Concepts
Computer Science
ISBN:
9780078022159
Author:
Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Publisher:
McGraw-Hill Education
Starting Out with Python (4th Edition)
Starting Out with Python (4th Edition)
Computer Science
ISBN:
9780134444321
Author:
Tony Gaddis
Publisher:
PEARSON
Digital Fundamentals (11th Edition)
Digital Fundamentals (11th Edition)
Computer Science
ISBN:
9780132737968
Author:
Thomas L. Floyd
Publisher:
PEARSON
C How to Program (8th Edition)
C How to Program (8th Edition)
Computer Science
ISBN:
9780133976892
Author:
Paul J. Deitel, Harvey Deitel
Publisher:
PEARSON
Database Systems: Design, Implementation, & Manag…
Database Systems: Design, Implementation, & Manag…
Computer Science
ISBN:
9781337627900
Author:
Carlos Coronel, Steven Morris
Publisher:
Cengage Learning
Programmable Logic Controllers
Programmable Logic Controllers
Computer Science
ISBN:
9780073373843
Author:
Frank D. Petruzella
Publisher:
McGraw-Hill Education