Look at the code and the sample inputs and outputs below to design the program accordingly. 1. Write a class called Color that only adds the 3 primary colors (red, blue and yellow). 2. Write a required constructor for the class. 3. You have to use operator overloading to get the desired outputs as shown. Hint: There will be only one constructor and only one method tackling the addition operation. No other methods are required. Note: Order of the color given as input should not matter. For example, in sample input 1, if the first input was yellow and then red, the output would still be orange. Sample Input 1: First Color: red Second Color: yellow #Write your code here #Do not change the following lines of code C1 = Color(input("First Color: ").lower()) C2 = Color(input("Second Color: ").lower()) С3 3 С1 + С2 print("Color formed:", C3.clr) Sample Output 1: Color formed: Orange Sample Input 2: First Color: red Second Color: blue Sample Output 2: Color formed: Violet Sample Input 3: First Color: yellow Second Color: BLUE Sample Output 3: Color formed: Green

Database System Concepts
7th Edition
ISBN:9780078022159
Author:Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Publisher:Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Chapter1: Introduction
Section: Chapter Questions
Problem 1PE
icon
Related questions
Question
Look at the code and the sample inputs and outputs below to design the program
accordingly.
1. Write a class called Color that only adds the 3 primary colors (red, blue and
yellow).
2. Write a required constructor for the class.
3. You have to use operator overloading to get the desired outputs as shown.
Hint:
There will be only one constructor and only one method tackling the addition operation.
No other methods are required.
Note: Order of the color given as input should not matter. For example, in sample input
1, if the first input was yellow and then red, the output would still be orange.
Sample Input 1:
First Color: red
Second Color: yellow
#Write your code here
#Do not change the following lines of code
C1 = Color(input("First Color: ").lower())
C2 = Color(input("Second Color: ").lower())
C3 = C1 + C2
print("Color formed:", C3.clr)
Sample Output 1:
Color formed: Orange
%3D
Sample Input 2:
First Color: red
Second Color: blue
Sample Output 2:
Color formed: Violet
Sample Input 3:
First Color: yellow
Second Color: BLUE
Sample Output 3:
Color formed: Green
Transcribed Image Text:Look at the code and the sample inputs and outputs below to design the program accordingly. 1. Write a class called Color that only adds the 3 primary colors (red, blue and yellow). 2. Write a required constructor for the class. 3. You have to use operator overloading to get the desired outputs as shown. Hint: There will be only one constructor and only one method tackling the addition operation. No other methods are required. Note: Order of the color given as input should not matter. For example, in sample input 1, if the first input was yellow and then red, the output would still be orange. Sample Input 1: First Color: red Second Color: yellow #Write your code here #Do not change the following lines of code C1 = Color(input("First Color: ").lower()) C2 = Color(input("Second Color: ").lower()) C3 = C1 + C2 print("Color formed:", C3.clr) Sample Output 1: Color formed: Orange %3D Sample Input 2: First Color: red Second Color: blue Sample Output 2: Color formed: Violet Sample Input 3: First Color: yellow Second Color: BLUE Sample Output 3: Color formed: Green
Expert Solution
steps

Step by step

Solved in 3 steps with 2 images

Blurred answer
Knowledge Booster
Development strategies
Learn more about
Need a deep-dive on the concept behind this application? Look no further. Learn more about this topic, computer-science and related others by exploring similar questions and additional content below.
Similar questions
Recommended textbooks for you
Database System Concepts
Database System Concepts
Computer Science
ISBN:
9780078022159
Author:
Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Publisher:
McGraw-Hill Education
Starting Out with Python (4th Edition)
Starting Out with Python (4th Edition)
Computer Science
ISBN:
9780134444321
Author:
Tony Gaddis
Publisher:
PEARSON
Digital Fundamentals (11th Edition)
Digital Fundamentals (11th Edition)
Computer Science
ISBN:
9780132737968
Author:
Thomas L. Floyd
Publisher:
PEARSON
C How to Program (8th Edition)
C How to Program (8th Edition)
Computer Science
ISBN:
9780133976892
Author:
Paul J. Deitel, Harvey Deitel
Publisher:
PEARSON
Database Systems: Design, Implementation, & Manag…
Database Systems: Design, Implementation, & Manag…
Computer Science
ISBN:
9781337627900
Author:
Carlos Coronel, Steven Morris
Publisher:
Cengage Learning
Programmable Logic Controllers
Programmable Logic Controllers
Computer Science
ISBN:
9780073373843
Author:
Frank D. Petruzella
Publisher:
McGraw-Hill Education