CIS204_2
.docx
keyboard_arrow_up
School
ECPI University, Greensboro *
*We aren’t endorsed by this school
Course
204
Subject
Computer Science
Date
Jan 9, 2024
Type
docx
Pages
4
Uploaded by corada5995
CIS204
2.1 – Port Security
Corey Adams, Jorge Cortes,
Stephen Harlow, Christopher Lee
1.
What are the steps involved to configure port security? SUMMARY STEPS
1. configure terminal
2. interface interface-id
3. switchport mode {access | trunk}
4. switchport voice vlan vlan-id
5. switchport port-security
6. switchport port-security [maximum value [vlan {vlan-list | {access | voice}}]]
7. switchport port-security violation {protect | restrict | shutdown | shutdown vlan}
8. switchport port-security [mac-address mac-address [vlan {vlan-id | {access | voice}}]
9. switchport port-security mac-address sticky
10. switchport port-security mac-address sticky [mac-address | vlan {vlan-id | {access | voice}}]
11. end
12. show port-security
13. copy running-config startup-config
2.
How do we see a security violation?
show port-security - This command displays port security information about all the interfaces on switch.
CIS204
2.1 – Port Security
Corey Adams, Jorge Cortes,
Stephen Harlow, Christopher Lee
3.
What are the different port security violation modes? Choose one of these modes and explain how it works.
1.
Protect
—when the number of secure MAC addresses reaches the maximum limit allowed on the port, packets with unknown source addresses are dropped until you remove enough secure MAC addresses to drop below the maximum value or increase the number of maximum allowable addresses. You are not notified that a security violation has occurred.
2.
Restrict
—when the number of secure MAC addresses reaches the maximum limit allowed on the port, packets with unknown source addresses are dropped until you remove enough secure MAC addresses to drop below the maximum value or increase the number of maximum allowable addresses. In this mode, you are notified that a security violation has occurred. An SNMP trap is sent, a syslog message is logged, and the violation counter increments.
3.
Shutdown
—a port security violation causes the interface to become error-disabled and to
shut down immediately, and the port LED turns off. When a secure port is in the error-
disabled state, you can bring it out of this state by entering the err disable recovery secure-violation global configuration command, or you can manually re-enable it by entering the shutdown and no shut down interface configuration commands. This is the default mode.
CIS204
2.1 – Port Security
Corey Adams, Jorge Cortes,
Stephen Harlow, Christopher Lee
4.
Using the drawing, configure port security on Switch1 to only allow PC0 on FA0/1. Choose a security violation as well. Share your commands.
Switch1#
configure terminal
Switch1(config)#
interface fa0/1
Switch1(config-if)#
switchport mode access
Switch1(config-if)#
switchport port-security
Switch1(config-if)#
switchport port-security maximum 1
Switch1(config-if)#
switchport port-security mac-address 0060:2F35:6102
Switch1(config-if)#
switchport port-security violation restrict
5.
Using the drawing, configure port security on Switch2 on FA0/20 to “sticky learn” the MAC-address. Choose a security violation as well. Share your commands.
Switch2#
configure terminal
Switch2(config)#
interface fa0/20
Switch2(config-if)#
switchport mode access
Switch2(config-if)#
switchport port-security
Switch2(config-if)#
switchport port-security maximum 1
Switch2(config-if)#
switchport port-security mac-address sticky
Switch2(config-if)#
switchport port-security violation restrict
Your preview ends here
Eager to read complete document? Join bartleby learn and gain access to the full version
- Access to all documents
- Unlimited textbook solutions
- 24/7 expert homework help
CIS204
2.1 – Port Security
Corey Adams, Jorge Cortes,
Stephen Harlow, Christopher Lee
6.
Using the drawing, how can we configure port security on Switch1 to not allow more
than three devices on Switch2? Choose a security violation as well. Share your commands.
Switch#
configure terminal
Switch(config)#
interface g0/1
Switch(config-if)#
switchport mode access
Switch(config-if)#
switchport port-security
Switch(config-if)#
switchport port-security maximum 3
Switch(config-if)#
switchport port-security mac-address sticky
Switch(config-if)#
switchport port-security violation restrict
References
Switchport Port Security Explained With Examples
. (2018, August). Retrieved from ComputerNetworkingNotes: https://www.computernetworkingnotes.com/ccna-study-
guide/switchport-port-security-explained-with-examples.html
Related Questions
This is an HTTP question please show work and explain accordingly (1 question, 4 parts)
arrow_forward
In this assignment, you will develop a simple Web server in Python that is capable of processing only one request. Specifically, your Web server will (i) Create a connection socket when contacted by a client (browser) (ii) Receive the HTTP request from this connection(iii) Parse the request to determine the specific file being requested(iv) Get the requested file from the server’s file system(v) Create an HTTP response message consisting of the requested file preceded by header lines(vi) Send the response over the TCP connection to the requesting browser. If a browser requests a file that is not present in your server, your server should return a “404 Not Found” error message. Your job is to code the steps above, run your server, and then test your server by sending requests from browsers running on different hosts. If you run your server on a host that already has a Web server running on it, then you should use a different port than port 80 for your Web server. Make sure to test your…
arrow_forward
Q10: Complete the frames (x & y) given below with appropriate port, IP and MAC addresses. The
sender Host E has two applications running; one for email with port number 49254 and the other for
accessing the web server with port number 52167. The frame x is intended for the BRACU Web server
and frame y is coming from the Email Server. (MAC addresses are alphabets and IP addresses are
numbers) [5]
Port 80
Frame y
K/93
BRACU G/51
Router
BRACU Web
ISP
Frame x
Server
Router I/91
Port 25
Н 52
F/25
Hub-PT
Hubo
A/20
Switc-PT
Switcho
Swich-Pr
Syitch1
Email
Server
J/92
B/21
E/24
C/22
D/23
Sender
Frame X
D. Mac
S. MAC
D. IP
S. IP
D. Port
S. Port
Data
Trailer
Frame Y
D. Mac
S. MAC
D. IP
S. IP
D. Port
S. Port
Data
Trailer
**
*******END***:
***
***
*****
arrow_forward
Primitives of transport service assume asymmetry between the two end points during connection establishment, one end (server) executes LISTEN while the other end (client) executes CONNECT.
However, in peer to peer applications such file sharing systems, e.g. BitTorrent, all end points are peers.
There is no server or client functionality.
How can transport service primitives may be used to build such peer to peer applications?
arrow_forward
1 IntroductionThe objective of this project is to learn TCP client-server interaction using a socket interface in C programming language. After completing this Project, you will have a basic understanding of the steps required todevelop a networking application.
2 Project SpecificationIn this project, you are required to do socket programming in C language (Linux environment) to implementa pair of client and server that can achieve simple password verification to indicate the current market valueof the stock. Your client will send a pair of username and password to your server and your server willverify whether the pair of username and password is legitimate or not for retrieving the stock value. Assumethe only legitimate pairs of usernames and passwords that will be accepted by your server are as follows.
Username Password StockValuelcid welpa23e 13.93mrvl ghqwo31a 41.23snap tyjli14d 10.21cl1 rjwqe83f 85.09bro gnmds28z 56.43cvs rhktl87c 91.34…
arrow_forward
Question 23
A client's browser sends an HTTP request to a website. The website responds with a handshake and
sets up a TCP connection. The connection setup takes 2.1 ms, including the RTT. The browser then
sends the request for the website's index file. The index file references 8 additional images, which
are to be requested/downloaded by the client's browser.
Assuming all other conditions are equal, how much longer would non-persistent HTTP take than
persistent HTTP? (Give answer in milliseconds, without units, rounded to one decimal place. For an
answer of 0.01005 seconds, you would enter "10.1" without the quotes.)
arrow_forward
SEE MORE QUESTIONS
Recommended textbooks for you
Management Of Information Security
Computer Science
ISBN:9781337405713
Author:WHITMAN, Michael.
Publisher:Cengage Learning,
Related Questions
- This is an HTTP question please show work and explain accordingly (1 question, 4 parts)arrow_forwardIn this assignment, you will develop a simple Web server in Python that is capable of processing only one request. Specifically, your Web server will (i) Create a connection socket when contacted by a client (browser) (ii) Receive the HTTP request from this connection(iii) Parse the request to determine the specific file being requested(iv) Get the requested file from the server’s file system(v) Create an HTTP response message consisting of the requested file preceded by header lines(vi) Send the response over the TCP connection to the requesting browser. If a browser requests a file that is not present in your server, your server should return a “404 Not Found” error message. Your job is to code the steps above, run your server, and then test your server by sending requests from browsers running on different hosts. If you run your server on a host that already has a Web server running on it, then you should use a different port than port 80 for your Web server. Make sure to test your…arrow_forwardQ10: Complete the frames (x & y) given below with appropriate port, IP and MAC addresses. The sender Host E has two applications running; one for email with port number 49254 and the other for accessing the web server with port number 52167. The frame x is intended for the BRACU Web server and frame y is coming from the Email Server. (MAC addresses are alphabets and IP addresses are numbers) [5] Port 80 Frame y K/93 BRACU G/51 Router BRACU Web ISP Frame x Server Router I/91 Port 25 Н 52 F/25 Hub-PT Hubo A/20 Switc-PT Switcho Swich-Pr Syitch1 Email Server J/92 B/21 E/24 C/22 D/23 Sender Frame X D. Mac S. MAC D. IP S. IP D. Port S. Port Data Trailer Frame Y D. Mac S. MAC D. IP S. IP D. Port S. Port Data Trailer ** *******END***: *** *** *****arrow_forward
- Primitives of transport service assume asymmetry between the two end points during connection establishment, one end (server) executes LISTEN while the other end (client) executes CONNECT. However, in peer to peer applications such file sharing systems, e.g. BitTorrent, all end points are peers. There is no server or client functionality. How can transport service primitives may be used to build such peer to peer applications?arrow_forward1 IntroductionThe objective of this project is to learn TCP client-server interaction using a socket interface in C programming language. After completing this Project, you will have a basic understanding of the steps required todevelop a networking application. 2 Project SpecificationIn this project, you are required to do socket programming in C language (Linux environment) to implementa pair of client and server that can achieve simple password verification to indicate the current market valueof the stock. Your client will send a pair of username and password to your server and your server willverify whether the pair of username and password is legitimate or not for retrieving the stock value. Assumethe only legitimate pairs of usernames and passwords that will be accepted by your server are as follows. Username Password StockValuelcid welpa23e 13.93mrvl ghqwo31a 41.23snap tyjli14d 10.21cl1 rjwqe83f 85.09bro gnmds28z 56.43cvs rhktl87c 91.34…arrow_forwardQuestion 23 A client's browser sends an HTTP request to a website. The website responds with a handshake and sets up a TCP connection. The connection setup takes 2.1 ms, including the RTT. The browser then sends the request for the website's index file. The index file references 8 additional images, which are to be requested/downloaded by the client's browser. Assuming all other conditions are equal, how much longer would non-persistent HTTP take than persistent HTTP? (Give answer in milliseconds, without units, rounded to one decimal place. For an answer of 0.01005 seconds, you would enter "10.1" without the quotes.)arrow_forward
arrow_back_ios
arrow_forward_ios
Recommended textbooks for you
- Management Of Information SecurityComputer ScienceISBN:9781337405713Author:WHITMAN, Michael.Publisher:Cengage Learning,
Management Of Information Security
Computer Science
ISBN:9781337405713
Author:WHITMAN, Michael.
Publisher:Cengage Learning,