Problem Solving with C++ (9th Edition)
Problem Solving with C++ (9th Edition)
9th Edition
ISBN: 9780133591743
Author: Walter Savitch
Publisher: PEARSON
bartleby

Concept explainers

Expert Solution & Answer
Book Icon
Chapter 18.3, Problem 19STE

Explanation of Solution

Modified code:

The modified code for given display 18.17 is shown below:

//Header file

#include <iostream>

#include <list>

#include <algorithm>

//std namespace

using std::cin;

using std::cout;

using std::endl;

using std::list;

using std::find;

//Min function

int main( )

{

        /* Declare line in "list" template */

        list<char> line;

        /* Display prompt statement */

    cout << "Enter a line of text:\n";

        //Declare variable for "next"

        char next;

    /* Read text from user */

        cin.get(next);

        /* If "next" is not equal to "\n" */

        while (next != '\n')

        {

            /* Insert the character to list */

            line.push_back(next);

            /* Read the next character */

            cin.get(next);

        }

  /* Declare char varaible "where" in constant iterator */

        list<char>::const_iterator where;

  /* where is located at the first occurrence of 'e' in line.*/

        where = find(line.begin( ), line.end( ), 'e');

  /* Declare char variable "p" in constant iterator */

    list<char>::const_iterator p;

        /* Display statement */

  cout << "You entered the following before you entered your first e:\n";

  /* Using "for" loop, display located at the first occurrence of 'e' in line */

        for (p = line...

Blurred answer
Students have asked these similar questions
give typed code and compiler screenshot with output
You are tasked to implement an abstract data type class which takes in a given input file called input.txt, and processes, identifies and sorts all unique word instances found in the file. Sample Input Hi hello hi good bye goodbye Bye bye good say Sample Output Bye Hi bye hello hi say The input.txt file is found along with the zip folder where this instructions file also came along with. Note: you are not allowed to use pythonic lists, and its methods and functions, and string methods. However the use of the file handling methods (read readlines and readline) are allowed for this project.
C++ Coding only put the code where it says solution goes here. Don’t change anything else
Knowledge Booster
Background pattern image
Computer Science
Learn more about
Need a deep-dive on the concept behind this application? Look no further. Learn more about this topic, computer-science and related others by exploring similar questions and additional content below.
Similar questions
SEE MORE QUESTIONS
Recommended textbooks for you
Text book image
Database System Concepts
Computer Science
ISBN:9780078022159
Author:Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Publisher:McGraw-Hill Education
Text book image
Starting Out with Python (4th Edition)
Computer Science
ISBN:9780134444321
Author:Tony Gaddis
Publisher:PEARSON
Text book image
Digital Fundamentals (11th Edition)
Computer Science
ISBN:9780132737968
Author:Thomas L. Floyd
Publisher:PEARSON
Text book image
C How to Program (8th Edition)
Computer Science
ISBN:9780133976892
Author:Paul J. Deitel, Harvey Deitel
Publisher:PEARSON
Text book image
Database Systems: Design, Implementation, & Manag...
Computer Science
ISBN:9781337627900
Author:Carlos Coronel, Steven Morris
Publisher:Cengage Learning
Text book image
Programmable Logic Controllers
Computer Science
ISBN:9780073373843
Author:Frank D. Petruzella
Publisher:McGraw-Hill Education