WRITE CODE IN C LANGUANGE On their way down the river, Jojo and Lili saw two frogs each in position X1 and X2. The two frogs are seen jumping happily towards the same direction that is come to Jojo. After watching the two frogs, Joig and Lili saw that the speed the two frogs are different. The first frog to start jumping from position X1 has a speed of V1, while the second frog that starts to jump from position X2 has a speed of v2. Jojo guess that "YES" both frogs will be in the same position in a certain time T, while Bibi guessing "NO" the two frogs will never be in the same position in time. Help Joio and Lili calculate the frog's movements to determine whether the guess they are right. Input Format • The first line of input consists of a series of integers namely X1, V1, X2, V2, T. • X1 and V1 are the initial position and jump speed per second of the first frog. • X2 and V2 are the starting position and jump speed per second of the second frog. • Tis the second when the frog jumps. Output Format • A string "YES" or "NO" Constraints 1sTs104 Os X1,X2 s 10+ 1sV1, V2 s 104 Sample Input 0 3 4 2 10 Sample Output YES Sample Input 0 3 4 2 3 Sample Output NO In the sample above, let's say that frogs A and B start jumping together. Frog A starts jumping from position 0 at a speed of 3 per second. Then frog A's position per second: 3, 6, 9, 12, 15. etc. • Frog B starts jumping from position 4 at a rate of 2 per second. Then frog B's position per second: 6, 8, 10, 12, 14. etc. Within 3 seconds, the two frogs will NOT be in the same position. The two frogs can be in the same position in the fourth second, namely in position 12. So within 10 seconds the output is YES whereas within 3 seconds the output is NO.
Answer in C language
I have implemented the above requirements in C as per the specification. Comments are mentioned for better understanding of the code. The code is as follows:
#include <stdio.h>
int main()
{
int x1, v1, x2, v2, t;
scanf("%d %d %d %d %d", &x1, &v1, &x2, &v2, &t);
int i = 0;
int flag = 0;
//Initialize the first distance with x1 and x2
int d1 = x1, d2 = x2;
//Run the loop for the time given
for(i = 0; i < t; i++){
//Increment whichever distance is less
if(d1 < d2){
d1 += v1;
}
else if(d2 < d1){
d2 += v2;
}
//Check for equality
//If equal the make flag = 1 and break out of the loop
else{
flag = 1;
break;
}
}
//Print the answer based on the value of flag
if(flag == 1){
printf("YES");
}
else{
printf("NO");
}
return 0;
}
Step by step
Solved in 2 steps with 1 images