Write a program that calculates the area of some simple figures (i.e. a square and a rectangle). One function per figure. Check if the function arguments are greater than 0 – if they aren't, throw an exception. This program should use your own exceptions to communicate with a higher-level code. Add some attribute in your exception to pass a message to the user. Some boilerplate code is included below.

Database System Concepts
7th Edition
ISBN:9780078022159
Author:Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Publisher:Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Chapter1: Introduction
Section: Chapter Questions
Problem 1PE
icon
Related questions
Question

pls help answer this question in c++

Lab 7.2.1 Exceptions: catch block
Objectives
Familiarize the student with:
• handling exceptions;
writing his/her own exception classes;
• passing additional information in exceptions;
Scenario
Write a program that calculates the area of some simple figures (i.e. a square and a rectangle). One function per figure. Check if the
function arguments are greater than 0 – if they aren't, throw an exception. This program should use your own exceptions to
communicate with a higher-level code. Add some attribute in your exception to pass a message to the user. Some boilerplate code is
included below.
#include <iostream>
using namespace std;
//add your own exception class here
//add functions code here
int main(void) {
float a, b, r;
cin >> a;
cin >> b;
try
{
square_area(a);
rectangle_area(a,b);
float rsquare
float rrectangle
cout <« rsquare << endl « rrectangle << endl;
}
//add a suitable catch block here
return 0;
Example input
2
1
Example output
4
Page 1 / 1
+
-
Transcribed Image Text:Lab 7.2.1 Exceptions: catch block Objectives Familiarize the student with: • handling exceptions; writing his/her own exception classes; • passing additional information in exceptions; Scenario Write a program that calculates the area of some simple figures (i.e. a square and a rectangle). One function per figure. Check if the function arguments are greater than 0 – if they aren't, throw an exception. This program should use your own exceptions to communicate with a higher-level code. Add some attribute in your exception to pass a message to the user. Some boilerplate code is included below. #include <iostream> using namespace std; //add your own exception class here //add functions code here int main(void) { float a, b, r; cin >> a; cin >> b; try { square_area(a); rectangle_area(a,b); float rsquare float rrectangle cout <« rsquare << endl « rrectangle << endl; } //add a suitable catch block here return 0; Example input 2 1 Example output 4 Page 1 / 1 + -
Expert Solution
steps

Step by step

Solved in 3 steps with 5 images

Blurred answer
Knowledge Booster
Exception Handling Keywords
Learn more about
Need a deep-dive on the concept behind this application? Look no further. Learn more about this topic, computer-science and related others by exploring similar questions and additional content below.
Recommended textbooks for you
Database System Concepts
Database System Concepts
Computer Science
ISBN:
9780078022159
Author:
Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Publisher:
McGraw-Hill Education
Starting Out with Python (4th Edition)
Starting Out with Python (4th Edition)
Computer Science
ISBN:
9780134444321
Author:
Tony Gaddis
Publisher:
PEARSON
Digital Fundamentals (11th Edition)
Digital Fundamentals (11th Edition)
Computer Science
ISBN:
9780132737968
Author:
Thomas L. Floyd
Publisher:
PEARSON
C How to Program (8th Edition)
C How to Program (8th Edition)
Computer Science
ISBN:
9780133976892
Author:
Paul J. Deitel, Harvey Deitel
Publisher:
PEARSON
Database Systems: Design, Implementation, & Manag…
Database Systems: Design, Implementation, & Manag…
Computer Science
ISBN:
9781337627900
Author:
Carlos Coronel, Steven Morris
Publisher:
Cengage Learning
Programmable Logic Controllers
Programmable Logic Controllers
Computer Science
ISBN:
9780073373843
Author:
Frank D. Petruzella
Publisher:
McGraw-Hill Education