Sum of two arrays Given a problem and correct (shuffled) program, re-arrange the shuffled code segments in the correct order. Consider a program that finds the sum of the corresponding elements in two arrays. { display(a,b,n): int" create(int n) for(i=0;i read(a,n): read(b,n); int i; The next 'n' integers correspond to the elements in the first array. The last 'n' integers correspond to the elements in the second array. #include scanf("%d",a+i); for (i=0:i

Computer Networking: A Top-Down Approach (7th Edition)
7th Edition
ISBN:9780133594140
Author:James Kurose, Keith Ross
Publisher:James Kurose, Keith Ross
Chapter1: Computer Networks And The Internet
Section: Chapter Questions
Problem R1RQ: What is the difference between a host and an end system? List several different types of end...
icon
Related questions
Question

KINDLY SEE ATTACH IMAGE FOR THE QUESTION. REARRANGE SHUFFLED PROGRAM GIVEN IN RIGHT SIDE OF IMAGE TO SOLVE QUESTION. AFTER REARRANGING MATCH SAMPLE INPUT AND OUTPUT PROVIDED IN QUESTION BELOW.

-----------------------------------------------------------------------

Sample Input 1:
 

5

2

3

6

8

1

1

1

1

1

1


Sample Output 1:
 

3 4 7 9 2

Sum of two arrays
Given a problem and correct (shuffled) program, re-arrange the shuffled code segments in the correct order.
Consider a program that finds the sum of the corresponding elements in two arrays.
{|
{
display(a,b,n);
int" create(int n)
{
for(i=0;i<n;i++)
Input Format:
a=create(n);
int *a"b,n;
b=create(n):
void read(int "aint n)
}
{
#include<stdio.h>
read(a,n):
read(b,n):
int i;
Input consists of 2n+1 integers. The first integer corresponds to 'n', the size of the array.
The next 'n' integers correspond to the elements in the first array. The last 'n' integers correspond to the
elements in the second array.
#include<stdlib.h>
scanf("%d",a+i);
for (i=0;i<n;i++)
int" create(int):
int *a;
Assume that the maximum value of n is 15.
void read(int"int):
return a;
printf("%d "sum);
inti sum;
Output Format:
void display(int*int",int);
scanf("%d",&n);
return 0;
}
int main()
sum="(a+i)+*(b+i);
a=(int")malloc(n'sizeof(int));
void display(int *a,int *b,int n)
Refer to sample output for details.
Transcribed Image Text:Sum of two arrays Given a problem and correct (shuffled) program, re-arrange the shuffled code segments in the correct order. Consider a program that finds the sum of the corresponding elements in two arrays. {| { display(a,b,n); int" create(int n) { for(i=0;i<n;i++) Input Format: a=create(n); int *a"b,n; b=create(n): void read(int "aint n) } { #include<stdio.h> read(a,n): read(b,n): int i; Input consists of 2n+1 integers. The first integer corresponds to 'n', the size of the array. The next 'n' integers correspond to the elements in the first array. The last 'n' integers correspond to the elements in the second array. #include<stdlib.h> scanf("%d",a+i); for (i=0;i<n;i++) int" create(int): int *a; Assume that the maximum value of n is 15. void read(int"int): return a; printf("%d "sum); inti sum; Output Format: void display(int*int",int); scanf("%d",&n); return 0; } int main() sum="(a+i)+*(b+i); a=(int")malloc(n'sizeof(int)); void display(int *a,int *b,int n) Refer to sample output for details.
Expert Solution
trending now

Trending now

This is a popular solution!

steps

Step by step

Solved in 4 steps with 2 images

Blurred answer
Recommended textbooks for you
Computer Networking: A Top-Down Approach (7th Edi…
Computer Networking: A Top-Down Approach (7th Edi…
Computer Engineering
ISBN:
9780133594140
Author:
James Kurose, Keith Ross
Publisher:
PEARSON
Computer Organization and Design MIPS Edition, Fi…
Computer Organization and Design MIPS Edition, Fi…
Computer Engineering
ISBN:
9780124077263
Author:
David A. Patterson, John L. Hennessy
Publisher:
Elsevier Science
Network+ Guide to Networks (MindTap Course List)
Network+ Guide to Networks (MindTap Course List)
Computer Engineering
ISBN:
9781337569330
Author:
Jill West, Tamara Dean, Jean Andrews
Publisher:
Cengage Learning
Concepts of Database Management
Concepts of Database Management
Computer Engineering
ISBN:
9781337093422
Author:
Joy L. Starks, Philip J. Pratt, Mary Z. Last
Publisher:
Cengage Learning
Prelude to Programming
Prelude to Programming
Computer Engineering
ISBN:
9780133750423
Author:
VENIT, Stewart
Publisher:
Pearson Education
Sc Business Data Communications and Networking, T…
Sc Business Data Communications and Networking, T…
Computer Engineering
ISBN:
9781119368830
Author:
FITZGERALD
Publisher:
WILEY