R progra
Computer Networking: A Top-Down Approach (7th Edition)
7th Edition
ISBN:9780133594140
Author:James Kurose, Keith Ross
Publisher:James Kurose, Keith Ross
Chapter1: Computer Networks And The Internet
Section: Chapter Questions
Problem R1RQ: What is the difference between a host and an end system? List several different types of end...
Related questions
Question
R progranmming
![11:54 AM Fri Jun 3
1☎ 54%
Sum in Range
PROBLEM
CODE
RESULT
You need to create a function that takes two parameters and returns the sum of all numbers between the two parameters
inclusive.
The given code takes two numbers from input and passes them to a function called rangeSum().
Task
Define the rangeSum() function, so that the code works as expected.
Sample Input
4
9
Sample Output
[1] 39
Explanation
For the inputs 4 and 9, the returned value should be 39.
Use the for loop inside the function to execute the required calculation.
START SOLVING](/v2/_next/image?url=https%3A%2F%2Fcontent.bartleby.com%2Fqna-images%2Fquestion%2Fae98b63a-c1e0-40a0-8ef8-c296ebcafc68%2Fe184eba3-334c-4931-8c53-7dfb77961173%2Fwvu95tk_processed.png&w=3840&q=75)
Transcribed Image Text:11:54 AM Fri Jun 3
1☎ 54%
Sum in Range
PROBLEM
CODE
RESULT
You need to create a function that takes two parameters and returns the sum of all numbers between the two parameters
inclusive.
The given code takes two numbers from input and passes them to a function called rangeSum().
Task
Define the rangeSum() function, so that the code works as expected.
Sample Input
4
9
Sample Output
[1] 39
Explanation
For the inputs 4 and 9, the returned value should be 39.
Use the for loop inside the function to execute the required calculation.
START SOLVING
![11:55 AM Fri Jun 3
PROBLEM
1 input <- readLines('stdin')
2 x <- as.integer (input [1])
3
y <- as.integer(input [2])
4
5 #define the function
6 for (4:9)
7 X <- x + 1
8
9 result <- rangeSum(x, y)
10 print (result)
TAB (
1111
Sum in Range
CODE
RESULT
···BOЕ•••••«»•I«
)
=
[ ] +
%
<= >=
&
<
V
! !=
1☎ 54%
TT
r
RUN▶](/v2/_next/image?url=https%3A%2F%2Fcontent.bartleby.com%2Fqna-images%2Fquestion%2Fae98b63a-c1e0-40a0-8ef8-c296ebcafc68%2Fe184eba3-334c-4931-8c53-7dfb77961173%2Fp3dim47_processed.png&w=3840&q=75)
Transcribed Image Text:11:55 AM Fri Jun 3
PROBLEM
1 input <- readLines('stdin')
2 x <- as.integer (input [1])
3
y <- as.integer(input [2])
4
5 #define the function
6 for (4:9)
7 X <- x + 1
8
9 result <- rangeSum(x, y)
10 print (result)
TAB (
1111
Sum in Range
CODE
RESULT
···BOЕ•••••«»•I«
)
=
[ ] +
%
<= >=
&
<
V
! !=
1☎ 54%
TT
r
RUN▶
Expert Solution

This question has been solved!
Explore an expertly crafted, step-by-step solution for a thorough understanding of key concepts.
Step by step
Solved in 4 steps with 2 images

Recommended textbooks for you

Computer Networking: A Top-Down Approach (7th Edi…
Computer Engineering
ISBN:
9780133594140
Author:
James Kurose, Keith Ross
Publisher:
PEARSON

Computer Organization and Design MIPS Edition, Fi…
Computer Engineering
ISBN:
9780124077263
Author:
David A. Patterson, John L. Hennessy
Publisher:
Elsevier Science

Network+ Guide to Networks (MindTap Course List)
Computer Engineering
ISBN:
9781337569330
Author:
Jill West, Tamara Dean, Jean Andrews
Publisher:
Cengage Learning

Computer Networking: A Top-Down Approach (7th Edi…
Computer Engineering
ISBN:
9780133594140
Author:
James Kurose, Keith Ross
Publisher:
PEARSON

Computer Organization and Design MIPS Edition, Fi…
Computer Engineering
ISBN:
9780124077263
Author:
David A. Patterson, John L. Hennessy
Publisher:
Elsevier Science

Network+ Guide to Networks (MindTap Course List)
Computer Engineering
ISBN:
9781337569330
Author:
Jill West, Tamara Dean, Jean Andrews
Publisher:
Cengage Learning

Concepts of Database Management
Computer Engineering
ISBN:
9781337093422
Author:
Joy L. Starks, Philip J. Pratt, Mary Z. Last
Publisher:
Cengage Learning

Prelude to Programming
Computer Engineering
ISBN:
9780133750423
Author:
VENIT, Stewart
Publisher:
Pearson Education

Sc Business Data Communications and Networking, T…
Computer Engineering
ISBN:
9781119368830
Author:
FITZGERALD
Publisher:
WILEY