Let us define the custom tribonacci sequence as follows. To = A T₁ = B T₂ = C Ti = Ti-3 + Ti-2 + Ti-1 for i ≥ 3 Given A, B, C, and i, output T; mod 10⁹ +7 Input Format Input consists of one line containing four space-separated integers A, B, C, and i as des problem statement. Constraints 0 ≤ A, B, C, i ≤ 260 Output Format Output one line containing T; mod 10⁹ +7
Let us define the custom tribonacci sequence as follows. To = A T₁ = B T₂ = C Ti = Ti-3 + Ti-2 + Ti-1 for i ≥ 3 Given A, B, C, and i, output T; mod 10⁹ +7 Input Format Input consists of one line containing four space-separated integers A, B, C, and i as des problem statement. Constraints 0 ≤ A, B, C, i ≤ 260 Output Format Output one line containing T; mod 10⁹ +7
Database System Concepts
7th Edition
ISBN:9780078022159
Author:Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Publisher:Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Chapter1: Introduction
Section: Chapter Questions
Problem 1PE
Related questions
Question
100%
CTS Problem Set
Kindly answer using Divide and Conquer
Can be answered in Pypy 3 or Java 8

Transcribed Image Text:Sample Input 0
0 0 1 3
Sample Output 0
1
Sample Input 1
4224
Sample Output 1
12
Sample Input 2
2 116
Sample Output 2
21
1 def solve(a,b,c,i):
2
3556N
4
MOD
1000000007
# compute and return answer here
a, b, c, i = list (map
6 print (solve(a,b,c, i))
(int,input().rstrip().split(" ")))

Transcribed Image Text:Custom Tribonacci Sequence
Problem
= A
Submissions
Let us define the custom tribonacci sequence as follows.
To
T₁ = B
T₂ = C
Ti = Ti-3 + Ti-2 + Ti-1 for i ≥ 3
Given A, B, C, and i, output T; mod 10⁹ +7
Input Format
Input consists of one line containing four space-separated integers A, B, C, and i as described in the
problem statement.
Constraints
Discussions
0 ≤ A, B, C, i < 260
Output Format
Output one line containing T; mod 10⁹ +7
Expert Solution

This question has been solved!
Explore an expertly crafted, step-by-step solution for a thorough understanding of key concepts.
This is a popular solution!
Trending now
This is a popular solution!
Step by step
Solved in 3 steps with 3 images

Knowledge Booster
Learn more about
Need a deep-dive on the concept behind this application? Look no further. Learn more about this topic, computer-science and related others by exploring similar questions and additional content below.Recommended textbooks for you

Database System Concepts
Computer Science
ISBN:
9780078022159
Author:
Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Publisher:
McGraw-Hill Education

Starting Out with Python (4th Edition)
Computer Science
ISBN:
9780134444321
Author:
Tony Gaddis
Publisher:
PEARSON

Digital Fundamentals (11th Edition)
Computer Science
ISBN:
9780132737968
Author:
Thomas L. Floyd
Publisher:
PEARSON

Database System Concepts
Computer Science
ISBN:
9780078022159
Author:
Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Publisher:
McGraw-Hill Education

Starting Out with Python (4th Edition)
Computer Science
ISBN:
9780134444321
Author:
Tony Gaddis
Publisher:
PEARSON

Digital Fundamentals (11th Edition)
Computer Science
ISBN:
9780132737968
Author:
Thomas L. Floyd
Publisher:
PEARSON

C How to Program (8th Edition)
Computer Science
ISBN:
9780133976892
Author:
Paul J. Deitel, Harvey Deitel
Publisher:
PEARSON

Database Systems: Design, Implementation, & Manag…
Computer Science
ISBN:
9781337627900
Author:
Carlos Coronel, Steven Morris
Publisher:
Cengage Learning

Programmable Logic Controllers
Computer Science
ISBN:
9780073373843
Author:
Frank D. Petruzella
Publisher:
McGraw-Hill Education