Can you write a c program for the following output?

Database System Concepts
7th Edition
ISBN:9780078022159
Author:Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Publisher:Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Chapter1: Introduction
Section: Chapter Questions
Problem 1PE
icon
Related questions
Question
100%
Can you write a c program for the following output?
**Sample Input and Output Explanation**

This section demonstrates how specific numeric inputs generate an output pattern using asterisks. Below is a detailed description of the samples:

---

**Sample Input**

- **Input 1:** 5
- **Input 2:** 6

---

**Sample Output**

1. For an input of **5**, the corresponding output is a symmetrical pattern of asterisks shaped like an hourglass:

```
*****
 * *
  *
 * *
*****
```

2. For an input of **6**, the output is a symmetrical pattern of a larger hourglass with an additional row of asterisks:

```
******
 *  *
  * *
   *
  * *
 *  *
******
```

---

**Explanation:** 

- Each pattern starts and ends with a full row of asterisks matching the input number. 
- The rows between are formed by placing spaces symmetrically, reducing the number of asterisks towards the center to form the hourglass shape.
- These patterns visually demonstrate symmetry and centered alignment relative to the given input number.
Transcribed Image Text:**Sample Input and Output Explanation** This section demonstrates how specific numeric inputs generate an output pattern using asterisks. Below is a detailed description of the samples: --- **Sample Input** - **Input 1:** 5 - **Input 2:** 6 --- **Sample Output** 1. For an input of **5**, the corresponding output is a symmetrical pattern of asterisks shaped like an hourglass: ``` ***** * * * * * ***** ``` 2. For an input of **6**, the output is a symmetrical pattern of a larger hourglass with an additional row of asterisks: ``` ****** * * * * * * * * * ****** ``` --- **Explanation:** - Each pattern starts and ends with a full row of asterisks matching the input number. - The rows between are formed by placing spaces symmetrically, reducing the number of asterisks towards the center to form the hourglass shape. - These patterns visually demonstrate symmetry and centered alignment relative to the given input number.
Expert Solution
Step 1

Program:

 

#include <stdio.h>

int main()
{
     int number;
    
    printf("Input:\n");
    scanf("%d", &number); //reading number of rows or columns
    
    printf("\nOutput:\n");
    

   //loop to print pattern
    for (int i = 1; i <= number; i++){

      //for printing first and last row
        if (i == 1 || i == number){
            for (int j = 1; j <= number; j++)
                printf("*");
        }
        

       //for printing all rows except first and last
        else{
            for (int j = 1; j <= number; j++){
                if (j == 1 || j == number)
                    printf("*");
                else
                    printf(" ");
            }
        }
        
        printf("\n");
    }
    
    return 0;
}

trending now

Trending now

This is a popular solution!

steps

Step by step

Solved in 2 steps with 1 images

Blurred answer
Knowledge Booster
Print statement
Learn more about
Need a deep-dive on the concept behind this application? Look no further. Learn more about this topic, computer-science and related others by exploring similar questions and additional content below.
Similar questions
  • SEE MORE QUESTIONS
Recommended textbooks for you
Database System Concepts
Database System Concepts
Computer Science
ISBN:
9780078022159
Author:
Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Publisher:
McGraw-Hill Education
Starting Out with Python (4th Edition)
Starting Out with Python (4th Edition)
Computer Science
ISBN:
9780134444321
Author:
Tony Gaddis
Publisher:
PEARSON
Digital Fundamentals (11th Edition)
Digital Fundamentals (11th Edition)
Computer Science
ISBN:
9780132737968
Author:
Thomas L. Floyd
Publisher:
PEARSON
C How to Program (8th Edition)
C How to Program (8th Edition)
Computer Science
ISBN:
9780133976892
Author:
Paul J. Deitel, Harvey Deitel
Publisher:
PEARSON
Database Systems: Design, Implementation, & Manag…
Database Systems: Design, Implementation, & Manag…
Computer Science
ISBN:
9781337627900
Author:
Carlos Coronel, Steven Morris
Publisher:
Cengage Learning
Programmable Logic Controllers
Programmable Logic Controllers
Computer Science
ISBN:
9780073373843
Author:
Frank D. Petruzella
Publisher:
McGraw-Hill Education