b. Create a function solving for one root of a quadratic equation. (Note: Let +/- be only plus sign) #These imports are necessary. No need to modify the import statements. 2 from operator import truediv, mul, add 3 from math import sqrt 4 5 def quad HH Insert Code Below (15 lines are below. Use them all for full credit. White space and comments are not included.) -b+-4ac 2a Input Format The inputs are three numbers corresnonding to a b. and e Constraints You may assume that only va id combinations of a, b. and c will be Inputted. E.g. No quadratic equations with imaginary roots. No asci input, etc. 8. 9 10 Output Forma The output w ll be the INTEGER rcot computed for #This is a way of assigning three comma separated inputs into three int variables. It would be advisable to look into the input(), split(), and int() functions. No need to modify the two lines below. inl, in2, in3 = input().split(",") inl, in2, in3 = int(inl), int (in2), int(in3) 14 15 # HCall the function and print the result below. 16 Sample Input 0 1,4,4 Sample Output 0

Database System Concepts
7th Edition
ISBN:9780078022159
Author:Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Publisher:Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Chapter1: Introduction
Section: Chapter Questions
Problem 1PE
icon
Related questions
Question
100%

Need help using Python 3!

Note:

- you can only use truediv,mul,add, and sqrt

- Can NOT use sub or Subtraction, please help!!

- The code is given on the right side. Question on left. 

1. Using Python3, encode the following:
b. Create a function solving for one root of a quadratic equation. (Note: Let +/- be only plus sign)
#These imports are necessary. No need to modify the import statements.
from operator import truediv, mul, add
from math import sqrt
1
-b+\b2 –4ac
2a
2
3
Input Format
4
The inputs are three numbers corresponding to a, b, and c
def quad
### Insert Code Below (15 lines are below. Use them all for full credit. White space and comments are not included.)
Constraints
7
You may assume that only valld comblnatlons of a, b, and c wll be Inputted. E.g. No quadratic cquatlons w th
8
imaginary roots. No ascii input, etc.
###
10
#This is a way of assigning three comma separated inputs into three int variables. It would be advisable to look into the
input(), split(), and int() functions. No need to modify the two lines below.
12 inl, in2, in3 = input().split(",")
13 inl, in2, in3 = int(inl), int(in2), int(in3)
Output Format
The output will be the INTEGER root computed for.
11
Sample Input 0
14
1,4,4
15 ###Call the function and print the result below.
16
Sample Output 0
17
###End
2
Transcribed Image Text:1. Using Python3, encode the following: b. Create a function solving for one root of a quadratic equation. (Note: Let +/- be only plus sign) #These imports are necessary. No need to modify the import statements. from operator import truediv, mul, add from math import sqrt 1 -b+\b2 –4ac 2a 2 3 Input Format 4 The inputs are three numbers corresponding to a, b, and c def quad ### Insert Code Below (15 lines are below. Use them all for full credit. White space and comments are not included.) Constraints 7 You may assume that only valld comblnatlons of a, b, and c wll be Inputted. E.g. No quadratic cquatlons w th 8 imaginary roots. No ascii input, etc. ### 10 #This is a way of assigning three comma separated inputs into three int variables. It would be advisable to look into the input(), split(), and int() functions. No need to modify the two lines below. 12 inl, in2, in3 = input().split(",") 13 inl, in2, in3 = int(inl), int(in2), int(in3) Output Format The output will be the INTEGER root computed for. 11 Sample Input 0 14 1,4,4 15 ###Call the function and print the result below. 16 Sample Output 0 17 ###End 2
Expert Solution
steps

Step by step

Solved in 3 steps with 2 images

Blurred answer
Similar questions
Recommended textbooks for you
Database System Concepts
Database System Concepts
Computer Science
ISBN:
9780078022159
Author:
Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Publisher:
McGraw-Hill Education
Starting Out with Python (4th Edition)
Starting Out with Python (4th Edition)
Computer Science
ISBN:
9780134444321
Author:
Tony Gaddis
Publisher:
PEARSON
Digital Fundamentals (11th Edition)
Digital Fundamentals (11th Edition)
Computer Science
ISBN:
9780132737968
Author:
Thomas L. Floyd
Publisher:
PEARSON
C How to Program (8th Edition)
C How to Program (8th Edition)
Computer Science
ISBN:
9780133976892
Author:
Paul J. Deitel, Harvey Deitel
Publisher:
PEARSON
Database Systems: Design, Implementation, & Manag…
Database Systems: Design, Implementation, & Manag…
Computer Science
ISBN:
9781337627900
Author:
Carlos Coronel, Steven Morris
Publisher:
Cengage Learning
Programmable Logic Controllers
Programmable Logic Controllers
Computer Science
ISBN:
9780073373843
Author:
Frank D. Petruzella
Publisher:
McGraw-Hill Education