3. Complete the program Student Records that simulates a student records system. The program reads a list of student ids, names, and GPAs from a file exam.txt, and stores the information in parallel array lists ids, names, and gpas.

Database System Concepts
7th Edition
ISBN:9780078022159
Author:Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Publisher:Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Chapter1: Introduction
Section: Chapter Questions
Problem 1PE
icon
Related questions
Question
3. Complete the program Student Records that simulates a student records system. The
program reads a list of student ids, names, and GPAS from a file exam.txt, and stores the
information in parallel array lists ids, names, and gpas.
Sample input (exam.txt):
132 Woody 4.1
465 Buzz 3.1
443 Rex 2.8
124 Hamm 3.3
337 Jessie 4.2
Your program will display a GPA report.
You must include a method named reportByGPA (...) that accepts the required array lists
and minimum GPA and displays the list of students that meet the criteria.
Sample output:
Enter the minimum GPA:
4.0
Students with GPA of 4.0 or higher
132 Woody, GPA: 4.1
337 Jessie, GPA: 4.2
end of program
import java.util.ArrayList;
import java.util.Scanner;
import java.io.File;
import java.io.FileNotFoundException;
public class Student Records {
public static void main(String[] args) throws
FileNotFoundException (
Scanner f = new Scanner (new File ("exam.txt"));
Scanner kb = new Scanner (System.in);
ArrayList<Integer> ids = new ArrayList<> ();
ArrayList<String> names = new ArrayList<> ();
ArrayList<Integer> gpas = new ArrayList<> ();
Transcribed Image Text:3. Complete the program Student Records that simulates a student records system. The program reads a list of student ids, names, and GPAS from a file exam.txt, and stores the information in parallel array lists ids, names, and gpas. Sample input (exam.txt): 132 Woody 4.1 465 Buzz 3.1 443 Rex 2.8 124 Hamm 3.3 337 Jessie 4.2 Your program will display a GPA report. You must include a method named reportByGPA (...) that accepts the required array lists and minimum GPA and displays the list of students that meet the criteria. Sample output: Enter the minimum GPA: 4.0 Students with GPA of 4.0 or higher 132 Woody, GPA: 4.1 337 Jessie, GPA: 4.2 end of program import java.util.ArrayList; import java.util.Scanner; import java.io.File; import java.io.FileNotFoundException; public class Student Records { public static void main(String[] args) throws FileNotFoundException ( Scanner f = new Scanner (new File ("exam.txt")); Scanner kb = new Scanner (System.in); ArrayList<Integer> ids = new ArrayList<> (); ArrayList<String> names = new ArrayList<> (); ArrayList<Integer> gpas = new ArrayList<> ();
Expert Solution
steps

Step by step

Solved in 3 steps with 1 images

Blurred answer
Knowledge Booster
Concept of pointer parameter
Learn more about
Need a deep-dive on the concept behind this application? Look no further. Learn more about this topic, computer-science and related others by exploring similar questions and additional content below.
Similar questions
Recommended textbooks for you
Database System Concepts
Database System Concepts
Computer Science
ISBN:
9780078022159
Author:
Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Publisher:
McGraw-Hill Education
Starting Out with Python (4th Edition)
Starting Out with Python (4th Edition)
Computer Science
ISBN:
9780134444321
Author:
Tony Gaddis
Publisher:
PEARSON
Digital Fundamentals (11th Edition)
Digital Fundamentals (11th Edition)
Computer Science
ISBN:
9780132737968
Author:
Thomas L. Floyd
Publisher:
PEARSON
C How to Program (8th Edition)
C How to Program (8th Edition)
Computer Science
ISBN:
9780133976892
Author:
Paul J. Deitel, Harvey Deitel
Publisher:
PEARSON
Database Systems: Design, Implementation, & Manag…
Database Systems: Design, Implementation, & Manag…
Computer Science
ISBN:
9781337627900
Author:
Carlos Coronel, Steven Morris
Publisher:
Cengage Learning
Programmable Logic Controllers
Programmable Logic Controllers
Computer Science
ISBN:
9780073373843
Author:
Frank D. Petruzella
Publisher:
McGraw-Hill Education